Error: no se puede cargar el elemento visual: se espera que las rutas de unión formen un árbol. Dos caminos de unión a la tabla

Un usuario Pregunto ✅

MG83

Hola

Ahora recibo el error anterior desde que actualicé PowerBI Desktop y no cargará una imagen que parecía funcionar bien antes.

Tengo una relación activa que se une a la tabla y 2 relaciones inactivas que se unen en otra parte de la tabla, por lo que puedo usar Userrelationship para calcular más fácilmente usando DAX.

Contexto: Me uní a una tabla de personal unida a una tabla de operaciones donde es posible que el miembro del personal tenga uno de los 3 roles posibles dentro de una fila de datos. es decir, personal 1, personal 2, personal 3.

¿Alguna sugerencia / idea?

Gracias

MG83

En respuesta a v-shex-msft

Hola @ v-shex-msft

Gracias por las sugerencias.

Seleccioné más de un filtro en más de una tabla para el RLS que parecía chocar.

Lo arreglé simplemente creando una tabla dinámica y usando un filtro para el RLS.

Anónimo

Tuve el mismo problema. El problema estaba en la conexión bidireccional para un par de tablas en el modelo (Ambas en lugar de Única). Después de solucionar el problema se ha resuelto.

Hola @ MG83,

Dado que no puedo reproducir su problema, ¿puede proporcionar una muestra para reproducir su problema?

Además, puede probar los métodos siguientes para asegurarse de en qué parte apareció el problema:

1. Compruebe si el problema está relacionado con lo visual.

Intente usar la tabla anterior para crear una nueva imagen y verifique si el problema apareció nuevamente.

2. Compruebe si el problema está relacionado con la seguridad a nivel de fila.

Intente eliminar la seguridad de nivel de fila anterior, luego cree una nueva para probar si apareció el problema.

3. Verifique si el problema está relacionado con la relación.

Elimine las relaciones y vuelva a crear la relación y pruebe de nuevo.

Si lo anterior no es de ayuda, comparta información detallada sobre su problema.

Saludos,

Xiaoxin Sheng

MG83

En respuesta a v-shex-msft

Hola @ v-shex-msft

Gracias por las sugerencias.

Seleccioné más de un filtro en más de una tabla para el RLS que parecía chocar.

Lo arreglé simplemente creando una tabla dinámica y usando un filtro para el RLS.

Anónimo

En respuesta a MG83

¿Puede explicar cómo lo resolvió? Estoy teniendo el mismo problema en este momento.

Mahimabedi

En respuesta a MG83

enfrentando el mismo problema. ¿Puedes compartir cómo resolviste esto?

MG83

En respuesta a Mahimabedi

¿Tiene actualmente algún RLS en su tabla de hechos?

La forma en que resolví el problema es que había cambiado por RLS de la tabla de hechos a Mi tabla dinámica en su lugar, es decir, la tabla de Office que se vincula a todas mis tablas de hechos.

MG83

En respuesta a Mahimabedi

¿Tiene actualmente algún RLS en su tabla de hechos?

La forma en que resolví el problema es que había cambiado por RLS de la tabla de hechos a Mi tabla dinámica en su lugar, es decir, la tabla de Office que enlaza con todas mis tablas de hechos.

Bhartman30

En respuesta a MG83

¿Puede agregar más contexto a su solución?

Mariograffe

En respuesta a MG83

Hola MG83, ¿podrías darme algunos detalles sobre tu solución usando una tabla dinámica?

Tnx,

Mario

Mariograffe

En respuesta a MG83

Hola MG83, ¿podrías darme algunos detalles sobre tu tabla dinámica para solucionar el problema?

MG83

Para agregar a esto, creo que puede ser ya que he aplicado seguridad a nivel de fila.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *